Browser Requirements

The current release of Quickbase is supported on the following browsers:

While we don't test Quickbase on all browsers, we do expect that it works properly with other browsers that support HTML5, but are not on our list. As a general rule, the more recent versions of browsers have better support for the technologies used in today's web applications. Therefore, you'll experience better performance with Quickbase (and with other web applications) if you use the most recent version of your browser.

No matter what browser you use, you need to:

  • Enable JavaScript.

  • Enable cookies. Refer to your browser's help for information about enabling cookies (many modern browsers enable them by default).

  • Use a browser that supports the TLS 1.2 or above encryption protocol automatically. Quickbase will not work with any browser that does not support TLS 1.2 or above.